Budda Amp Forum

Discussion of Budda amps
 
HomeHome  FAQFAQ  SearchSearch  RegisterRegister  MemberlistMemberlist  UsergroupsUsergroups  Log in  

Share | 
 

 Budda SD45 II tube issues

View previous topic View next topic Go down 
AuthorMessage
jcm800



Posts : 3
Join date : 2009-09-02

PostSubject: Budda SD45 II tube issues   Wed Sep 02, 2009 10:28 am

Hey guys,

glad to see a Budda forum. I got a used SD 45 about 6 months ago. Had 6l6 power tubes installed when i got it, and sovtek pre - not sure the age on any of them. Anyways, played for awhile like that, and started getting what I though was the preamp 'crackle'. Replaced all the pre-amp tubes with three more Sovteks. Still heard the sound, and the amp failed. Replaced the power amp tubes with GT KT66 - still had trouble. Replaced the rectifier tube - still had trouble. Finally took it in to my tech - he checked it out, said the fixed bias was fine, and of course, couldn't get the amp to fail.

Last night it failed again. One of the KT66 tubes had a blueish/orangish glow towards the top of the tube. Swapped out for the old 6l6s i had sitting around, and played fine for a bit - then began to fail again.

Anyone else ever had this much trouble with a Budda? Is there some key thing I'm missing - like maybe it's not a tube-related problem? Any help would be appreciated.

Thanks,
Casey
Lawrence KS
Back to top Go down
View user profile
jcm800



Posts : 3
Join date : 2009-09-02

PostSubject: Re: Budda SD45 II tube issues   Tue Sep 15, 2009 3:22 pm

hmmm... turns out I more than likely have a power issue in my practice room. I cannot for the life of me get this thing to fail anywhere else.

One thing I did notice was the halogen lamp with a dimmer switch in my jam room seeming to have quite an effect on the amp, but not quite sure if that's the only problem or not. either way, the lamp is gone.
Back to top Go down
View user profile
 
Budda SD45 II tube issues
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» ac cheapens the pf52 oil filter
» Bias issues ST70
» Quick troubleshooting guide for Dynaco tube amps
» 2"Burrell Smokebox tube / smokebox door ring
» Tube Rolling with the ST120

Permissions in this forum:You cannot reply to topics in this forum
Budda Amp Forum :: Budda Superdrive-
Jump to: