Budda Amp Forum

Discussion of Budda amps
 
HomeHome  FAQFAQ  SearchSearch  RegisterRegister  MemberlistMemberlist  UsergroupsUsergroups  Log in  

Share | 
 

 new to budda amps and have a question about their effects loops.

View previous topic View next topic Go down 
AuthorMessage
moonman079



Posts : 1
Join date : 2010-02-10
Age : 38
Location : alabama

PostSubject: new to budda amps and have a question about their effects loops.   Wed Feb 10, 2010 11:13 pm

i just got a SD18 head. so far i like it alot. but i am having one problem i can not get my delay pedal to work right through the effects loop. when i turn it on i do not lose any volume but the repeats are very weak about half the volume they should be. the pedal is a tc electronic nova repeater. i am using mogami cables that are pretty new so they should not be the problem. i sprayed contact cleaner in the jacks like was suggested to me but nothing. the pedal sounds great through the front of the amp. but i like using the loop for my delays chorus reverb trem and flange. i was wondering if there was anything that you guys would suggest me try?
Back to top Go down
View user profile
 
new to budda amps and have a question about their effects loops.
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Question About Gladiator beasts.
» Dark Fusion / Mirror Force question
» Mark III Transformers
» ST-120 and Heat question
» Question about Reinforce Truth

Permissions in this forum:You cannot reply to topics in this forum
Budda Amp Forum :: Budda Superdrive-
Jump to: